Clicking Noise in HEMI

Discussion of the 5.7L-6.1L-6.4L HEMIs.

Moderator: scottm

Post Reply
J
Posts: 3
Joined: Thu Dec 04, 2003 2:38 pm
Location: Idaho

Clicking Noise in HEMI

Post by J » Thu Dec 04, 2003 4:13 pm

I recently had my 03 Dodge HD quad cab HEMI replaced with a new 03 LARIMIE version due to a driverside clicking noise that is very evident when ideling and the front driverside door open. The dealer has said that most all of their inventory have this noise & MOPAR'S star tech is aware of the problem but dosn't know what to do about it. Any one out there have a suggestion? My newest LARIMIE version at present time with 2500 miles on it, doesn't click so far.

My first HEMI also would surge after pulling a long steep grade and then coast through the valley below. I could see the RPM raise and lower in the tach, feel it in the seat, as well as hear it in the exhaust. Any Comments?

3rd problem. Although it only happened 3 times in 5 months the pickup would sputter-fart & lunge when first being started and backing up, and sputter-fart & lung forward before clearing up after 3-4 seconds. Comments?

HappyKillMore

Post by HappyKillMore » Fri Dec 05, 2003 8:43 am

I haven't had any of those 3 problems, even with a couple of 30-dgreee mornings recently. I don't spend much time idling with the door open though. I also haven't been pulling any loads, but I did drive up and down some pretty good grades traveling between Austin and Vegas.

The only problem I've had has been that incorrect lug nut torque problem, like in that other thread. I went to a small local dealership to get that fixed (before I joined the forum, so I didn't know it was a known problem). They just turned the rotors. Now the braking vibration is coming back with a vengeance, so I'll have to get it looked at again.

Post Reply