Help Strong Vibration when ideling and running

Discussion about the Hemi in general.

Moderator: scottm

Post Reply
allen
Posts: 21
Joined: Mon Feb 18, 2008 6:27 pm

Help Strong Vibration when ideling and running

Post by allen » Fri Aug 27, 2010 2:12 pm

I need some advise
Just installed a 68 block 426 hemi into my 72 cuda. Engine was totally rebuild from ground up and installed by a friend of mine. The engine was machined by a shop that went bankrupt while my engine was in the shop. It took almost a year to get it back and had to be put together by another shop. It starts first shot every time but vibrates like crazy at idel and when accelerated. I do not drive it for fear of damage. I have a feeling that the harmonic balancer ( vibration damper ) is incorrect. Any ideas? and how can I tell if the one on the car is the correct one in the first place. Any help would be much appreciated. The number on the balancer is 1604 2.

BlueDjinn
Posts: 54
Joined: Fri Aug 28, 2009 2:27 pm

Re: Help Strong Vibration when ideling and running

Post by BlueDjinn » Tue May 07, 2019 7:41 am

The number on the 1966-71 harmonic balancer or vibration damper for the 426 street HEMI is 2658871. For the 1964 race HEMI it is 2268905. For the 1965 race HEMI it is 2532975. The number 1604 2 is someone else's number. Doesn't come up. 2658871 is what you're looking for. And you will be looking for it. They're scarce. You don't mention as to whether components of the reciprocating assembly have been replaced. Same pistons? Same rods? If this engine was only apart for rings, bearings and a valve job, that shouldn't affect the balance of the engine. But it doesn't look like your damper is correct given that number 1604 2. If your pistons and rods were changed; or the crankshaft substituted with another, that throws everything into the mix. The assembly has to be balanced regardless of the damper. It's impossible to know what your friend did or did not do.

Post Reply